import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!<color=green>|[a-zA-Z0-9])(int|void|float|bool)(?!<\\/color>|[a-zA-Z0-9])";
final String string = "pulic int Example(float x, bool y, int z)\n"
+ "{\n"
+ " return y ? (int)x : z;\n"
+ "}\n\n"
+ "public <color=green>int</color> ExamepleAlreadyReplaced(<color=green>float</color> x, <color=green>bool</color> y, <color=green>int</color> z)\n"
+ "{\n"
+ " return y ? (<color=green>int</color>)x : z;\n"
+ "}\n\n"
+ "public void EdgeCaseKeyWordsInNames()\n"
+ "{\n"
+ " var someint = int.MinValue;;\n"
+ " var somefloat = float.MaxValue;\n"
+ " var somebool = false;\n"
+ " var somevoid = () => { };\n"
+ " \n"
+ " var int2 = 0;\n"
+ " var intX = 0;\n"
+ "}";
final String subst = "<color=green>$1</color>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}