# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<!<color=green>|[a-zA-Z0-9])(int|void|float|bool)(?!<\/color>|[a-zA-Z0-9])"
test_str = ("pulic int Example(float x, bool y, int z)\n"
"{\n"
" return y ? (int)x : z;\n"
"}\n\n"
"public <color=green>int</color> ExamepleAlreadyReplaced(<color=green>float</color> x, <color=green>bool</color> y, <color=green>int</color> z)\n"
"{\n"
" return y ? (<color=green>int</color>)x : z;\n"
"}\n\n"
"public void EdgeCaseKeyWordsInNames()\n"
"{\n"
" var someint = int.MinValue;;\n"
" var somefloat = float.MaxValue;\n"
" var somebool = false;\n"
" var somevoid = () => { };\n"
" \n"
" var int2 = 0;\n"
" var intX = 0;\n"
"}")
subst = "<color=green>$1</color>"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.