package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(009665|9665|\+9665|05|5)(5|0|3|6|4|9|1|8|7)([0-9]{7})$`)
var str = `00966504439483`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}