re = /^(009665|9665|\+9665|05|5)(5|0|3|6|4|9|1|8|7)([0-9]{7})$/
str = '00966504439483'
# Print the match result
str.match(re) do |match|
puts match.to_s
end