$re = '/^[0-9]+(?!\.)\D*$/m';
$str = '42. blabla \\n foo
42 blabla \\n foo
422. blabla \\n foo';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);