re = /^[0-9]+(?!\.)\D*$/m
str = '42. blabla \\n foo
42 blabla \\n foo
422. blabla \\n foo'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end