$re = '/Example(\d+)/m';
$str = 'Example1 another text 123 Example2 text';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);