import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\d+)?[\\ \\t*]*(?:\\[AS(\\d*)\\])?[\\ \\t]+([\\w\\.]+)[\\ \\t]+\\(([\\d+\\.]+)\\)[\\ \\t]+(.*?)[\\ \\t]*$";
final String string = "1 10.33.128.1 (10.33.128.1) 4.452 ms 3.459 ms 3.474 ms \n"
+ "6 * [AS3356] 4.68.72.218 (4.68.72.218) 12.432 ms 11.819 ms \n"
+ " * 4.68.72.218 (4.68.72.218) 12.432 ms 11.819 ms \n"
+ " 61.182.180.62 (61.182.180.62) 175.300 ms 203.001 ms";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}