# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(\d+)?[\ \t*]*(?:\[AS(\d*)\])?[\ \t]+([\w\.]+)[\ \t]+\(([\d+\.]+)\)[\ \t]+(.*?)[\ \t]*$"
test_str = ("1 10.33.128.1 (10.33.128.1) 4.452 ms 3.459 ms 3.474 ms \n"
"6 * [AS3356] 4.68.72.218 (4.68.72.218) 12.432 ms 11.819 ms \n"
" * 4.68.72.218 (4.68.72.218) 12.432 ms 11.819 ms \n"
" 61.182.180.62 (61.182.180.62) 175.300 ms 203.001 ms")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.