$re = '/<meta name="generator" content="Subrion CMS ([\d\.]+)*/m';
$str = '<meta name="generator" content="Subrion CMS 3.3.4.10';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);