package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[0-9a-fA-F]{8}\-[0-9a-fA-F]{4}\-[0-9a-fA-F]{4}\-[0-9a-fA-F]{4}\-[0-9a-fA-F]{12}`)
var str = `6a2f41a3-c54c-fce8-32d2-0324e1c32e22`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}