$re = '/^(?:7\d{10}|421\d{9})$/m';
$str = '71234567890
421123456789
7123
42112345678910';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);