const regex = /(\d+.*?)\s?cm/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d+.*?)\\s?cm', 'g')
const str = `23 cm
43 1/2 cm
20cm
15 cm x 30 cm`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}