$re = '/(\d+.*?)\s?cm/';
$str = '23 cm
43 1/2 cm
20cm
15 cm x 30 cm';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);