package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)(?:^|^\s|[^\/a-zA-Z0-9])tr|fr\s?([0-9]+).*$`)
var str = ` tr123456 fr593844`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}