$re = '/(?:^|^\s|[^\/a-zA-Z0-9])tr|fr\s?([0-9]+).*$/im';
$str = ' tr123456 fr593844';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);