#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?ix) c ["'] \K | (?<=\G) [^"']*? \K \w+"
Local $sString = "c"word & word" = word + word" & @CRLF & _
"c"12 = word" + word" & @CRLF & _
"c word & word = word + word" & @CRLF & _
"c 12 = word + word"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")