import re
regex = re.compile(r"[0-9]*?((?'isLeapYear'(00|04|08|12|16|20|24|28|32|36|40|44|48|52|56|60|64|6|72|76|80|84|88|92|96)(00|04|08|12|16|20|24|28|32|36|40|44|48|52|56|60|64|68|72|76|80|84|88|92|96)|[0-9][0-9](04|08|12|16|20|24|28|32|36|40|44|48|52|56|60|64|68|72|76|80|84|88|92|96))|[0-9][0-9][0-9][0-9])\/((?'oddMonth'0?1|0?3|0?5|0?7|0?9|11)|(?'evenMonth'0?4|0?6|0?8|10|12)|(?'February'0?2))\/(?(oddMonth)([1-2][0-9]|3[0-1]|0?[1-9])|(?(evenMonth)([1-2][0-9]|30|0?[1-9])|(?(February)(?(isLeapYear)([1-2][0-9]|0?[1-9])|(1[0-9]|2[0-8]|0?[1-9]))|(?!))))")
test_str = "2020/2/29"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")