$re = '/\w*\s*=\s*/m';
$str = 'something = is equal to = something
something = is equal to = something
something =is equal to = something';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);