re = /\w*\s*=\s*/m
str = 'something = is equal to = something
something = is equal to = something
something =is equal to = something'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end