const regex = /^(?>.+\n)*.*?\bcat\b.*(?:\n.+)*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?>.+\\n)*.*?\\bcat\\b.*(?:\\n.+)*', 'gm')
const str = `Paragraph 1 wepfowfpo
fww efwf
Paragraph 2 wefwf32321
!@d r33tcat54, 333!..
Paragraph 3 4t4t022
-\`121231ere3r3cat342232
\$ 4t0g cat rdwd203
\$\$333
Paragraph 4 222cocdo3`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}