import re
regex = re.compile(r"^(?>.+\n)*.*?\bcat\b.*(?:\n.+)*", flags=re.MULTILINE)
test_str = ("Paragraph 1 wepfowfpo\n"
"fww efwf\n\n"
"Paragraph 2 wefwf32321\n"
"!@d r33tcat54, 333!..\n\n"
"Paragraph 3 4t4t022\n"
"-`121231ere3r3cat342232\n"
"$ 4t0g cat rdwd203 \n"
"$$333\n\n"
"Paragraph 4 222cocdo3")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")