import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!`)(`(?:`{2})?)(?:(?!\\1).)*?\\1(*SKIP)(*F)|\"([^\"]*)\"";
final String string = "When copy/pasting commands that start with `cat << \"EOF\"`, select all lines at once (from `cat << \"EOF\"` to `EOF` inclusively) as they are part of the same (single) command\n\n"
+ "Figuring out how to ignore the above quoted strings is an interesting \"rabbit hole\".";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}