$re = '/(?<!`)(`(?:`{2})?)(?:(?!\1).)*?\1(*SKIP)(*F)|"([^"]*)"/m';
$str = 'When copy/pasting commands that start with `cat << "EOF"`, select all lines at once (from `cat << "EOF"` to `EOF` inclusively) as they are part of the same (single) command
Figuring out how to ignore the above quoted strings is an interesting "rabbit hole".';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);