import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<ip>((?:[0-9]{1,3}\\.){3}[0-9]{1,3})).+(?P<request>(GET|POST|HEAD|PUT|DELETE|CONNECT|OPTIONS|TRACE|PATCH)).(?P<endpoint>(.+endpoint1\\/health)|(.+endpoint1)|(.+)(\\?)|(.+) ).+\\\".(?P<status>([0-9]{3}))";
final String string = "INFO: 172.0.0.1:0 - \"POST /endpoint1/UNIQUE-ID?key=unique_value HTTP/1.1\" 200 OK\n"
+ "INFO: 172.0.0.2:0 - \"GET /endpoint/health HTTP/1.1\" 200 OK\n"
+ "172.0.0.1:0 - - [04/Mar/2022:10:52:10 -0500] \"GET /endpoint2/optimize HTTP/1.1\" 200 271\n"
+ "INFO: 172.0.0.3:0 :0 - \"GET /endpoint3?key=unique_value HTTP/1.1\" 200 OK";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}