# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?P<ip>((?:[0-9]{1,3}\.){3}[0-9]{1,3})).+(?P<request>(GET|POST|HEAD|PUT|DELETE|CONNECT|OPTIONS|TRACE|PATCH)).(?P<endpoint>(.+endpoint1\/health)|(.+endpoint1)|(.+)(\?)|(.+) ).+\".(?P<status>([0-9]{3}))"
test_str = ("INFO: 172.0.0.1:0 - \"POST /endpoint1/UNIQUE-ID?key=unique_value HTTP/1.1\" 200 OK\n"
"INFO: 172.0.0.2:0 - \"GET /endpoint/health HTTP/1.1\" 200 OK\n"
"172.0.0.1:0 - - [04/Mar/2022:10:52:10 -0500] \"GET /endpoint2/optimize HTTP/1.1\" 200 271\n"
"INFO: 172.0.0.3:0 :0 - \"GET /endpoint3?key=unique_value HTTP/1.1\" 200 OK")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.