using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"03(?=[0-9]{9})[0-9]{9}|[+]923(?=[0-9]{9})[0-9]{9}";
string input = @"03106671653";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}