$re = '/03(?=[0-9]{9})[0-9]{9}|[+]923(?=[0-9]{9})[0-9]{9}/';
$str = '03106671653';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);