$re = '/([\s\S].*?)([.*=,])?/m';
$str = 'John is happy. He owns 3*4=12, apples';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);