#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\bid\s+:\s*\b([0-9a-f]{8}\b-[0-9a-f]{4}-[0-9a-f]{4}-[0-9a-f]{4}-\b[0-9a-f]{12})\b"
Local $sString = "id : 42cdb643-0a11-416b-b66b-7bb28a9a20ea" & @CRLF & _
"isReadOnly : False" & @CRLF & _
"somestring : False" & @CRLF & _
"somestring : {}" & @CRLF & _
"name : " & @CRLF & _
"" & @CRLF & _
"id : d006d69e-8d04-48d7-8806-cdc39c18e679" & @CRLF & _
"somestring : False" & @CRLF & _
"somestring : False" & @CRLF & _
"somestring : 822F0340-818A-4F23-AA78-633B6436913F" & @CRLF & _
"upstreamDataflowsOfDatasets : {}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")