# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\bid\s+:\s*\b([0-9a-f]{8}\b-[0-9a-f]{4}-[0-9a-f]{4}-[0-9a-f]{4}-\b[0-9a-f]{12})\b"
test_str = ("id : 42cdb643-0a11-416b-b66b-7bb28a9a20ea\n"
"isReadOnly : False\n"
"somestring : False\n"
"somestring : {}\n"
"name : \n\n"
"id : d006d69e-8d04-48d7-8806-cdc39c18e679\n"
"somestring : False\n"
"somestring : False\n"
"somestring : 822F0340-818A-4F23-AA78-633B6436913F\n"
"upstreamDataflowsOfDatasets : {}")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.