package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\bx|X\b`)
var str = `bo x er
box
in a box 2
canine, dog, X boxer, XBreed, x `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}