$re = '/\bx|X\b/m';
$str = 'bo x er
box
in a box 2
canine, dog, X boxer, XBreed, x ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);