$re = '/"[\s\w]*"(*SKIP)(*F)|"[^"]*"/m';
$str = 'What should match: "Sel&ect" "+" " - " What should not match "Select","wow" "Seelct" & "wow"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);