re = /"[\s\w]*"(*SKIP)(*F)|"[^"]*"/m
str = 'What should match: "Sel&ect" "+" " - " What should not match "Select","wow" "Seelct" & "wow"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end