# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([a-zA-Z_]\w+|[a-zA-Z]\w*|\[\s*[a-zA-Z_]\w+\s*\]|\[\s*[a-zA-Z]\w*\s*\])\s*\[\s*['"]([a-zA-Z_]\w+|[a-zA-Z]\w*)['"]\s*\]/$1.$2/gm;t' <<< "a['b'][c]
a['1']
a['b1']
a[1]
a['_'] --I am pretty sure this is bad to match
a[\"__\"] --idk if this is bad to match
a[\"_ _\"]
a[\"up\"]
a[\"up \"]
a['b']['c'] --notice how this doesn't match the first quote with the last one
a[\"workwork\"]
_adf [ 'test' ] --even when imporoperlly formated this is valid lua
a.[b] [\"yup\"] --this case preserves the [b] and will append .yup after it
a[\"a.basdf\"]
\"adlfkajsd.dklajdlakj\""