import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\d)x(\\d+)\\)";
final String string = "A(1x5)BC\n"
+ "ADVENT\n"
+ "A(1x5)BC\n"
+ "(3x3)XYZ\n"
+ "A(2x2)BCD(2x2)EFG\n"
+ "(6x1)(1x3)A\n"
+ "X(8x2)(3x3)ABCY\n"
+ "1x5)BC";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}