re = /^(\d)x(\d+)\)/m
str = 'A(1x5)BC
ADVENT
A(1x5)BC
(3x3)XYZ
A(2x2)BCD(2x2)EFG
(6x1)(1x3)A
X(8x2)(3x3)ABCY
1x5)BC'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end