package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:https?://)?[^:/\n?]+`)
var str = `https://www.example.com
http://www.example.com
www.example.com
example.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}