re = /^(?:https?:\/\/)?[^:\/\n?]+/m
str = 'https://www.example.com
http://www.example.com
www.example.com
example.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end