re = /"(?!.*")/
str = 'myStr = "item1 item2 item3"
myStr2 = """item1"" ""item2"" ""item3"""'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end