#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!(?:com\.docker\.|io\.docker\.|org\.dockerproject\.))(?=.*[a-z]$)[a-z](?:[a-z0-9]|(?<!\.)\.(?!\.)|(?<!-)-(?!-)|\/|_)*$"
Local $sString = "com.docker.evil" & @CRLF & _
"01234" & @CRLF & _
"-a" & @CRLF & _
"a-" & @CRLF & _
".a" & @CRLF & _
"a." & @CRLF & _
"0abc" & @CRLF & _
"abc0" & @CRLF & _
"foo..bar" & @CRLF & _
"baz--fiz" & @CRLF & _
"goofy🙄ahh" & @CRLF & _
"a" & @CRLF & _
"correct.label" & @CRLF & _
"correct-label" & @CRLF & _
"also_correct__yes" & @CRLF & _
"according_/to_docker/this//is__valid" & @CRLF & _
"label4a"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")