$re = '/^(?!(?:com\.docker\.|io\.docker\.|org\.dockerproject\.))(?=.*[a-z]$)[a-z](?:[a-z0-9]|(?<!\.)\.(?!\.)|(?<!-)-(?!-)|\/|_)*$/m';
$str = 'com.docker.evil
01234
-a
a-
.a
a.
0abc
abc0
foo..bar
baz--fiz
goofy🙄ahh
a
correct.label
correct-label
also_correct__yes
according_/to_docker/this//is__valid
label4a';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);