using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=<Number>)[\d\s]+(?=<\/Number>)";
string input = @"<Number>65
46
4564
132
654
132
1565
</Number>
<Number>65
46
4564
132
654
132
1565
</Number>
<Number>65
46
4564
132
654
132
1565
</Number>
<Number>65
46
4564
132
654
132
1565
</Number>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}