import Foundation
let pattern = #"(?<=<Number>)[\d\s]+(?=<\/Number>)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<Number>65
46
4564
132
654
132
1565
</Number>
<Number>65
46
4564
132
654
132
1565
</Number>
<Number>65
46
4564
132
654
132
1565
</Number>
<Number>65
46
4564
132
654
132
1565
</Number>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)