#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mU)(https:\/\/|http:\/\/).+\..+\/|(http\:\/\/|)localhost(\:(\d+$))"
Local $sString = "https://dev.combustion911.com/products/industrial-gas-valves/solenoid/vmr-vml/" & @CRLF & _
"" & @CRLF & _
"localhost:8080"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")