$re = '/^(?=.*?\baaa)(?=.*?\bbbb)(?=.*?\bccc)(?:(aaa|bbb|ccc) ?\b)+$/m';
$str = 'aaa ccc bbb
aaa ccc
aaa bbb ddd ccc
bbb aaa bbb ccc
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);