import re
regex = re.compile(r"^(?=.*?\baaa)(?=.*?\bbbb)(?=.*?\bccc)(?:(aaa|bbb|ccc) ?\b)+$", flags=re.MULTILINE)
test_str = ("aaa ccc bbb\n"
"aaa ccc\n"
"aaa bbb ddd ccc\n"
"bbb aaa bbb ccc\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")