import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\[\\^)([^\\s\\p{C}\\]]+)(\\])\\ ([\\P{C}\\n]*?)(?=\\n\\[|\\n\\n\\n|\\Z)";
final String string = "Pseudo-example:\n\n"
+ "Sentence of the first [^a]paragraph. Sentence[^b] of the first[^b] paragraph[^1]. Sentence of the first[^1] paragraph. Sentence[^1] of the first paragraph. Sentence of the first paragraph. Sentence of the first paragraph. Sentence of the first paragraph.\n\n"
+ "[^a] Sentence of a long margin note's body that refers to the word \"paragraph\".\n\n"
+ "[^1] Sentence of the first paragraph of the footnote. Sentence of the first paragraph of the footnote. Sentence of the first paragraph of the footnote. Sentence of the first paragraph of the footnote.\n\n"
+ "Sentence of the second paragraph of the footnote. Sentence of the second paragraph of the footnote. Sentence of the second paragraph of the footnote. Sentence of the second paragraph of the footnote.\n\n"
+ "Sentence of the third and the last paragraph of the footnote and two empty lines after it!\n\n\n"
+ "Sentence[^1] of the second paragraph. Sentence of the second paragraph. Sentence of the second paragraph. Sentence of the second paragraph. Sentence of the second paragraph. Sentence of the second paragraph. Sentence of the second paragraph.\n\n"
+ "[^b] Footnote at the end of the file. Footnote at the end of the file. Footnote at the end of the file";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}