# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\/)(\d+)(\/?)/$1XYZ$3/gm;t' <<< "/users/12345 becomes /users/XXXXX
/users/234567/summary becomes /users/XXXXXX/summary
/api/v1/summary/5678 becomes /api/v1/summary/XXXX
http://example.com/api/v1/summary/5678/single becomes http://example.com/api/v1/summary/XXXX/single
"